2024 April - Footnotes not working

… at least not for me using the latest Alto theme on self-hosted Ghost v5.82.1 (FreeBSD 14, node18-18.19.1, npm-node18-10.2.5; no yarn).

I followed the instructions on using Markdown, and I don’t find this syntax to actually work.

What am I missing?

… created a Markdown card and started typing and added the [^1] after the word I wanted marked with a footnote. According to the instructions, I can create another Markdown card anywhere on the present page with [^1]: and add my reference text.

Markdown card1

Dr. Alberto Villoldo[^1] of the …

Markdown card5

[^1]: Dr. Alberto Villoldo, a devoted explorer 

Did Ghost’s help page not get updated with new syntax or some other details?

With markdown, all your footnotes must be contained in the same card. They can’t span multiple markdown cards.

1 Like

Thanks so much, Ryan, that’s the one option I didn’t try yet. I just reformatted my text into one Mardown card and you’re right, now it works!

When the Markdown Guide stated that I should add the footnote anywhere in the document, that meant to me, anywhere on that web page.

2. Then add the footnote anywhere in the document 
using the following Markdown: [^1]: My footnote

Suppose if someone rewrites that explanation it’ll be more clear :upside_down_face:

Thanks again!

Thanks for the feedback. I updated the docs to make it clear you need to add it in the same card.

Are you using markdown specifically to get footnote functionality or do you generally prefer to write your posts in markdown?

1 Like

I enjoy writing my posts in Markdown.

You get meaningful text formatting that is so easy and intuitive that I prefer it to html and css.

Now on to my next challenge: to create some kind of Archive layout or index … not sure how you’d call it, that would allow people easy access to older posts, some of which are still relevant … I’ve poked through developer how tos but I’m not at that level. Maybe changing the theme is a great caveman or simpleton approach to solving that problem.