Access settings of local Ghost install when offline?

Issue Summary

  • When I try to access the settings of the admin panel of a local Ghost install when I’m offline, it never loads (just displays animated Ghost logo). (The admin dashboard loads fine, it’s only the settings that are affected.) However, it starts working if I connect to a hotspot *before I have authenticated *, so it must be some kind of network check rather than a resource that it’s trying to load over the network.

    I don’t know whether this is a bug for everyone, something wrong with my config, or intended behavior. Do other people have the same problem?>

I have tried the recommendations here — running ghost buster to clear the yarn cache, deleting current/node_modules, and then running ghost update --force and restarting Ghost — without effect.

Steps to Reproduce

  1. Start local Ghost install when offline
  2. Try to load http://localhost:2368/ghost/#/settings

Setup information

Ghost Version
Share which version of Ghost you’re using.
Ghost-CLI version: 1.26.0
Ghost version: 5.82.11

Node.js Version
v20.13.1

How did you install Ghost?
With ghost-cli

Provide details of your host & operating system
Linux Mint

Database type
SQLite 3

Browser & OS version
Firefox 126, Chromium 124
Linux Mint 21.3 Virginia

Relevant log / error output
Nothing that I see in ghost log. In the console,

Failed to load resource: net::ERR_INTERNET_DISCONNECTED  (ghost.org/changelog.json:1)
        
TypeError: Network request failed
         at vendor-88d17cd9936471fdffa306a04f70e996.js:4783:90 (ghost-c52d8f1cb59e0b63db510a03624bd6c5.js:4417)


It could be a bug where Ghost has started to accidentally depend on being online for local development or perhaps fully offline development is not officially supported because it expects to be able to load some assets from a CDN. I’m not sure.

Either way, it would be great of offline development could work.

A bug fix was pushed here and will be included in the next release.

2 Likes

Wonderful! Thank you for the fast action @Kevin & @ronaldlangeveld :)

1 Like