Adding Spaces to Digital Ocean Droplet

Working on this:

Where does one find the details to update the config file as it states:

"storage": {
    "active" : "digitalocean",
    "digitalocean" : {
        "key": "YOUR_DIGITALOCEAN_SPACES_KEY",
      "secret" : "YOUR_DIGITALOCEAN_SPACES_SECRET",
      "region" : "YOUR_DIGITALOCEAN_SPACES_REGION",
      "bucket": "YOUR_DIGITALOCEAN_SPACES_BUCKET",
      "spaceUrl": "YOUR_DIGITALOCEAN_SPACES_URL",
      "subFolder": "OPTIONAL_SUB_FOLDER_NAME",
      "endpoint" : "${REGION}.digitaloceanspaces.com"
    }
}

@EBA have you signed up to a Spaces subscription and created a Space in your DigitalOcean dashboard? Docs for Spaces are here https://www.digitalocean.com/docs/spaces/

Once you’ve done that then the relevant API keys, secrets, and other information should be on the DigitalOcean dashboard for the Space which you have created.

Yea, I realized after my post that there’s spaces and volumes and they’re two different things.
Not sure why a volume won’t work in this case but I’ll go the spaces route and see if I manage :slight_smile:
Thank you!

Volumes wouldn’t require a storage adapter, you should be able to mount the volume in place of your Ghost site’s content directory because it would still act as if it was local storage.

1 Like

I think it actually is better practice to go with spaces.

The below settings are not being accepted. Specifically, the region is highlighted in red:

  "storage": {
    "active" : "digitalocean",
    "digitalocean" : {
        "key": "XXX",
      "secret" : "XXX",
      "region" : “nyc3”,
      "bucket": "atarlife-media",
      "spaceUrl": "https://media.atarlife.com",
      "endpoint" : "nyc3.digitaloceanspaces.com"
    }


I’m using Cloudflare as the CDN.

Still haven’t been able to solve this. If anyone is open to helping troubleshoot I’d really appreciate it! Eager to get Ghost live :grimacing: