After Digital Ocean, can't access non secure site

I just used DigitalOcean’s 1-Click Ghost installation.

  • What version of Ghost are you using?

  • What configuration?
    Ubuntu Ghost on 18.04

I’m trying to access the installation using my IP address or by typing in http://use_your_droplet_ip/ghost. In both instances that browser inserts a https:/ into the address and the browser won’t connect.

Do I need to set up Let’s Encrypt or something in order to see the site? I updated my DNS records a few hours ago and I can’t access the site.

Any pointers would be helpful

Here is a more detailed description of the problem. I have posted this in the Digital Ocean community. I’ll link back if I find the solution in either place.

My one click install went well. I’m able to ssh into the site, but I can’t access the site via IP.

The directions say

As soon as you’re done, make sure to configure the admin user using the administrative interface at http://use_your_droplet_ip/ghost (making sure to substitute the Droplet’s IP address in the URL). Until you configure the admin user, anyone who discovers the site can configure the administrative user, take control of the Ghost site, and potentially take control of the Droplet.

Every browser I use shifts the url from http://use_your_droplet_ip/ghost to https://use_your_droplet_ip/ghost.

I have taken these steps:

  1. Updated my A records from the place I bought the domain.
  2. Destroyed droplet and tried again
  3. Tried to turn off security in my browser
  4. Searched tutorials and read questions here

I’m stuck. How do I access http://use_your_droplet_ip/ghost?

1 Like

I am having this same issue.

Have you tried pointing a domain to your droplet and then configuring the domain and adding SSL to it ?

After pointing a domain your droplet, login to SSH

Switch to the ghost manager user:

sudo -i -u ghost-mgr

cd in to your ghost directory (default is /var/www/ghost)

cd /var/www/ghost

Set the domain for Ghost - > Run:

ghost config url


ghost setup nginx ssl

Switch blog URL to SSL address

ghost config url


ghost restart

1 Like

For anybody facing this issue in the future:

  1. Make sure any add-ons like uBlock, Adblock, Ghostery are deactivated or make your particular URL whitelisted.
  2. Wait for the DNS records to propagate, it can take up to 12 hours.

I had originally posted I was facing issues but they’ve now been resolved.

@sjmscott Not sure if you ever solved the problem.

This is likely to do with your nginx configuration. By default, through the one-click installer, an SSL certificate is created and your nginx config is updated to force https.

You shouldn’t need to ever view or enable the http version of your site.

Loading https://yourdomain/ghost/ should work.