Can't access ghost admin


I’ve recently setup up a DigitalOcean droplet, installed ghost 3.1.0 and combined it with a gatsby front-end deployed with netlify.

Last night everything was working well but now I can’t access my /ghost administration dashboard. Netlify shows my custom URL is set up and working correctly, my ghost instance is running still:

Thankyou for your help - really frustrating issue!

When I run ghost log I get this, if it helps:

It seems like you’re trying to run Ghost and Gatsby on the same domain - that’s not possible since they’re run by 2 different services. You can set the admin url in ghost using the command ghost config set admin.url and add DNS records to point to your Ghost instance and then access the Ghost administration panel there

Thank you for your help! I thought there could be a problem with both of them on the same domain. Ok I changed the admin URL and restarted ghost, what type of record needs to be set for this new configuration to work? Currently I have 3 NS records pointing to digitalocean nameservers and two A records pointing to the IP of my ghost install. I tried adding an a record pointing to the IP of my ghost droplet but I’m getting a 502 gateway error. What am I doing wrong?