Blog posts not showing content in preview or published

Issue Summary

  • I’m trying to put together my first blog in Ghost. I already created 10 blog posts, but in the half of them, some content won’t show up. If I add an image, in creator view it is visible, but in preview or published not. Same with built in components like headers or buttons etc. Even the Callout won’t show up. If I add or modify text, that change will appear. I’ve tried to crate a new blog post and copy the content into it, but the same happened. After creating 5-6 blog posts, all others stopped working.
  • Only the half of my blog posts works as expected. (Adding new image > shows up). I just simple can’t create more blog post because I can’t format them properly. How can I trust Ghost with a Pro subscription if only 5 out of my first 10 blog post works as expected?

Steps to Reproduce

  1. Creating a new blog post
  2. Adding text content
  3. Add image
  4. Add Callout
  5. Add Header section
  6. Select preview
  7. Only the text content is visible.
  8. Same with updating a blog post
  9. Deleting browser cache won’t help.

Setup information

Ghost Version

How did you install Ghost?

Provide details of your host & operating system
Include further details about your hosting and OS.

Database type

Hi! Welcome to the forum.

To clarify: Are you hosted by DigitalPress? is their site.
Ghost Pro is hosting by the team that runs - their customers have sites that end in, and you’d sign up at .

I’m not sure if anyone from Digital Press monitors this forum, so you may want to reach out to their support address, in case this is a quirk of something with the Digital Press setup.

To possibly get help here, it’d be super helpful if you could (1) link your site and (2) say what theme you’re using. If you’ve customized your theme at all, that would be good information to have. It sounds like the theme you’re using is broken in some way - you might try switching back to Casper and see if the problem disappears.

I’ve moved your post out of Bugs because it doesn’t sound like you’re reporting a Ghost bug but instead have an issue with either your theme or with something about the Digital Press setup.

1 Like

I’m having the same issue. The main image is visible but other images and an embedded YouTube link are showing in the editor but not in the published page. I changed my theme to the default Casper theme but it doesn’t help.

My blog is hosted on Midnight and it seems like this issue is not theme related.

I managed to “solve” the issue. There is something with the text formatting, and unfortunately, Ghost doesn’t provide a code view of the page, just the WYSIWYG editor, so I can’t figure it out, exactly where is the problem.

The solution:

  1. You have to create a totally new post or page
  2. And copy the text content without any of the previous formatting
  3. Redo the text formatting again

If you just copy/paste the previous text into the new post/page, the issue will remain. So copying the whole content won’t solve it. You have to clear the text formatting and paste the text without it. Also, you have to recreate callouts and any other “fancy” components. However, images can be copied/pasted.

I don’t know exactly which formatting causes this (H1, bold text, etc.), but somewhere Ghost generates a faulty code, and if it happens while editing your page, the final rendering won’t work anymore.

Thank you. I’ll try it out and see if it fixes it.

I tried it, exactly like you said and it didn’t work. I made a new post. copied only the plain text, retyped the H1, H2 headings and the title. I manually re-added the images but kept two hyperlinks when I copied the text.

It only shows my main image and not the images in the body.


I finally figured out that I had the beta editor switched on. Once I switched it off, and re-made the article in the old editor, it worked fine.

1 Like

Oh, yes, I forgot to mention that I turned the Beta Editor off. Thanks, I’ll update it with this info.

Can confirm the issue is still here in the last version. It’s a formatting issue, if trying to paste an already formatted article there is no way to save, preview or publish the content.

e.g to reproduce, paste this in a new article:

 text text
     this is code

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.