Bug? Double bookmark cards (Solved)

Just sent out my weekly newsletter, and noticed that every bookmark card is included twice. I only added them once, of course, so cannot fathom what made all of them show up in the final email twice.

Anyone else seen this? And if so, what caused it?

Still getting this error – every bookmark I include is doubled in the resulting email. They’re fine in the post on the site.

REALLY would like to fix this; incredibly annoying.


Can you tell us a bit more about your setup and potentially a live URL to a post that was sent and had double bookmarks in it? A screenshot of the email would also be good to get an understanding of it :slight_smile:

I just sent a newsletter from Ghost v5.82.1 the other day with bookmarks included and it all arrived correctly :thinking:

Site is hosted at Gloat Hosting, which doesn’t allow FTP access. So, I can’t troubleshoot on that end.

The newsletters are member-only, so I can’t give you a link. I can, however, provide a screen shot of one I just sent a while ago. Note that the duplicates don’t have the featured image.

What Ghost version are you on? You can check in Settings → About Ghost

I’ll then spin up an instance with that specific version and try to replicate it.

Version is 5.81.0

Thanks for your help!

Hm, I am afraid I am not of much help…

Just installed a fresh instance with v5.81.0 and created a new post with bookmarks.

This is how it looks as a post:

This is the newsletter:

Maybe you can ask Dan to have a quick look at logs to see if there were any anomalies there – and potentially at the database to see how the post is stored there?

Both could be shots in the dark – but this is where I would start looking to understand what’s happening.

Thanks for the try. Very odd. I’ll reach out to Dan at Gloat.

1 Like

So, after various troubleshooting tactics (downgrading theme version, checking code injection, and doing all this with a test email), I decided to send the test email to my Gmail account. Same issue.

Then I decided to check the test email in Gmail in the browser, rather than my regular email client.

And the test email was fine there.

Turns out the problem is caused by my email client, and not by Ghost. (I wondered why none of my members had complained.) First problem like this I’ve had with this email client.

So, marking this solved.