Build failed with Netlify


#1

when i use gatsby-starter-ghost in my netlify,it’s failed. like this:

7:30:09 PM: build-image version: 84aca9ba39e0ee86ba194760fbfc51a808f62543
7:30:10 PM: buildbot version: 57d44fd1631cc3fff8b38fbaf88d3d04f946418a
7:30:10 PM: Fetching cached dependencies
7:30:11 PM: Starting to download cache of 254.7KB
7:30:11 PM: Finished downloading cache in 195.049115ms
7:30:11 PM: Starting to extract cache
7:30:11 PM: Failed to fetch cache, continuing with build
7:30:11 PM: Starting to prepare the repo for build
7:30:12 PM: No cached dependencies found. Cloning fresh repo
7:30:12 PM: git clone https://github.com/pingkeung/gatsby-starter-ghost
7:30:14 PM: Preparing Git Reference refs/heads/master
7:30:14 PM: Found netlify.toml. Overriding site configuration
7:30:14 PM: Starting build script
7:30:14 PM: Installing dependencies
7:30:15 PM: Downloading and installing node v8.15.0...
7:30:15 PM: Downloading https://nodejs.org/dist/v8.15.0/node-v8.15.0-linux-x64.tar.xz...
7:30:16 PM:   1
7:30:16 PM: .4%
7:30:16 PM: #
7:30:16 PM: ##########################                                               38.5%
7:30:16 PM: 
#################################################################
7:30:16 PM: ####     97.1%
7:30:16 PM: #
7:30:16 PM: ######################################################################   99.3%
######################################################################## 100.0%
7:30:16 PM: Computing checksum with sha256sum
7:30:16 PM: Checksums matched!
7:30:18 PM: Now using node v8.15.0 (npm v6.4.1)
7:30:19 PM: Attempting ruby version 2.3.6, read from environment
7:30:20 PM: Using ruby version 2.3.6
7:30:20 PM: Using PHP version 5.6
7:30:20 PM: Started restoring cached node modules
7:30:20 PM: Finished restoring cached node modules
7:30:20 PM: Started restoring cached yarn cache
7:30:20 PM: Finished restoring cached yarn cache
7:30:20 PM: Installing yarn at version 1.3.2
7:30:20 PM: Installing Yarn!
7:30:20 PM: > Downloading tarball...
7:30:20 PM: [1/2]: https://yarnpkg.com/downloads/1.3.2/yarn-v1.3.2.tar.gz --> /tmp/yarn.tar.gz.8kihIFP4z5
7:30:20 PM:   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
7:30:20 PM:                                  Dload  Upload   Total   Spent    Left  Speed
7:30:20 PM: 
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100    91  100    91    0     0    880      0 --:--:-- --:--:-- --:--:--   883
7:30:20 PM: 
  0     0    0   608    0     0   1763      0 --:-
7:30:20 PM: -:-- --:--:-- --:--:--  1763
7:30:21 PM: 
 33  865k   33  288k    0
7:30:21 PM:    0   424k      0  0:00:02 --:--:--  0:00:02  424k
7:30:21 PM: 
100  865k  100  865k    0     0  121
7:30:21 PM: 4k      0 --:--:-- --:--:-- --:--:-- 17.6M
7:30:21 PM: [2/2]: https://yarnpkg.com/downloads/1.3.2/yarn-v1.3.2.tar.gz.asc --> /tmp/yarn.tar.gz.8kihIFP4z5.asc
7:30:21 PM: 
100    95  100    95    0     0   2289      0 --:--:-- --:--:-- --:--:--  2289
7:30:21 PM: 
  0     0    0   612    0     0   4608      0 --:--:-- --:--:-- --:--:--  4608
7:30:21 PM: 
100  1027  100  1027    0     0   59
7:30:21 PM: 54      0 --:--:-- --:--:-- --:--:--  5954
7:30:21 PM: > Verifying integrity...
7:30:21 PM: gpg: Signature made Thu 02 Nov 2017 04:44:10 PM UTC using RSA key ID FD2497F5
7:30:21 PM: gpg: Good signature from "Yarn Packaging <yarn@dan.cx>"
7:30:21 PM: gpg: Note: This key has expired!
7:30:21 PM: Primary key fingerprint: 72EC F46A 56B4 AD39 C907  BBB7 1646 B01B 86E5 0310
7:30:21 PM:      Subkey fingerprint: 6A01 0C51 6600 6599 AA17  F081 46C2 130D FD24 97F5
7:30:21 PM: > GPG signature looks good
7:30:21 PM: > Extracting to ~/.yarn...
7:30:21 PM: > Adding to $PATH...
7:30:21 PM: > We've added the following to your /opt/buildhome/.profile
7:30:21 PM: > If this isn't the profile of your current shell then please add the following to your correct profile:
7:30:21 PM: export PATH="$HOME/.yarn/bin:$HOME/.config/yarn/global/node_modules/.bin:$PATH"
7:30:21 PM: 
7:30:21 PM: > Successfully installed Yarn 1.3.2! Please open another terminal where the `yarn` command will now be available.
7:30:22 PM: Installing NPM modules using Yarn version 1.3.2
7:30:22 PM: yarn install v1.3.2
7:30:23 PM: [1/4] Resolving packages...
7:30:23 PM: [2/4] Fetching packages...
7:30:42 PM: info fsevents@1.2.4: The platform "linux" is incompatible with this module.
7:30:42 PM: info "fsevents@1.2.4" is an optional dependency and failed compatibility check. Excluding it from installation.
7:30:42 PM: [3/4] Linking dependencies...
7:30:42 PM: warning " > @tryghost/helpers-gatsby@1.0.0" has incorrect peer dependency "react@^16.7.0".
7:30:42 PM: warning "gatsby > gatsby-react-router-scroll@2.0.2" has unmet peer dependency "@reach/router@^1.0".
7:30:42 PM: warning "gatsby > mini-css-extract-plugin > schema-utils > ajv-errors@1.0.0" has unmet peer dependency "ajv@>=5.0.0".
7:30:50 PM: [4/4] Building fresh packages...
7:31:29 PM: Done in 67.15s.
7:31:30 PM: NPM modules installed using Yarn
7:31:30 PM: Started restoring cached go cache
7:31:30 PM: Finished restoring cached go cache
7:31:30 PM: unset GOOS;
7:31:30 PM: unset GOARCH;
7:31:30 PM: export GOROOT='/opt/buildhome/.gimme/versions/go1.10.linux.amd64';
7:31:30 PM: export PATH="/opt/buildhome/.gimme/versions/go1.10.linux.amd64/bin:${PATH}";
7:31:30 PM: go version >&2;
7:31:30 PM: export GIMME_ENV='/opt/buildhome/.gimme/env/go1.10.linux.amd64.env';
7:31:30 PM: go version go1.10 linux/amd64
7:31:30 PM: Installing missing commands
7:31:30 PM: Verify run directory
7:31:30 PM: Executing user command: gatsby build
7:31:33 PM: success open and validate gatsby-configs — 0.084 s
7:31:33 PM: success load plugins — 0.306 s
7:31:34 PM: success onPreInit — 0.726 s
7:31:34 PM: success delete html and css files from previous builds — 0.008 s
7:31:34 PM: success initialize cache — 0.009 s
7:31:34 PM: success copy gatsby files — 0.030 s
7:31:34 PM: success onPreBootstrap — 0.005 s
7:32:02 PM: success source and transform nodes — 28.278 s
7:32:02 PM: success building schema — 0.427 s
7:32:03 PM: success createPages — 0.340 s
7:32:03 PM: success createPagesStatefully — 0.130 s
7:32:03 PM: success onPreExtractQueries — 0.004 s
7:32:03 PM: success update schema — 0.308 s
7:32:03 PM: error GraphQL Error Unknown field `logo` on type `GhostSettings`
7:32:03 PM:   file: /opt/build/repo/src/utils/fragments.js
7:32:03 PM:    1 |
7:32:03 PM:    2 |     fragment GhostSettingsFields on GhostSettings {
7:32:03 PM:    3 |         title
7:32:03 PM:    4 |         description
7:32:03 PM: >  5 |         logo
7:32:03 PM:      |         ^
7:32:03 PM:    6 |         # icon
7:32:03 PM:    7 |         cover_image
7:32:03 PM:    8 |         facebook
7:32:03 PM:    9 |         twitter
7:32:03 PM:   10 |         lang
7:32:03 PM:   11 |         timezone
7:32:04 PM:   12 |         # ghost_head
7:32:04 PM:   13 |         # ghost_food
7:32:04 PM:   14 |         navigation {
7:32:04 PM:   15 |             label
7:32:04 PM: Caching artifacts
7:32:04 PM: Started saving node modules
7:32:04 PM: Finished saving node modules
7:32:04 PM: Started saving yarn cache
7:32:04 PM: Finished saving yarn cache
7:32:04 PM: Started saving pip cache
7:32:04 PM: Finished saving pip cache
7:32:04 PM: Started saving emacs cask dependencies
7:32:04 PM: Finished saving emacs cask dependencies
7:32:04 PM: Started saving maven dependencies
7:32:04 PM: Finished saving maven dependencies
7:32:04 PM: Started saving boot dependencies
7:32:04 PM: Finished saving boot dependencies
7:32:04 PM: Started saving go dependencies
7:32:04 PM: Finished saving go dependencies
7:32:04 PM: Cached node version v8.15.0
7:32:04 PM: Error running command: Build script returned non-zero exit code: 1
7:32:04 PM: Failing build: Failed to build site
7:32:04 PM: failed during stage 'building site': Build script returned non-zero exit code: 1
7:32:04 PM: Finished processing build request in 1m54.436078492s`

#2

You need to set a logo in the “General” screen of your Ghost admin panel. Gatsby requires all fields to be populated in order to build.

There’s details here:

The stub doesn’t add settings as it would override any settings you already have, we’re aware of that particular problem and tracking it here:


#3

thank you ,
Solved in your way。