Cannot install Ghost v1 for migration, because v1 requires version of Node too old for Ghost CLI

Hi there,
I am trying to follow this guide in order to import a JSON export from a Ghost v0.x blog into a current version of Ghost:

However, using the latest stable versions of Node, NPM, & Ghost-CLI, the command ghost install --v1 fails with:

✔ Checking system Node.js version - found v16.17.1
✔ Checking current folder permissions
✔ Checking memory availability
✔ Checking free space
✔ Checking for latest Ghost version
✔ Setting up install directory
✖ Downloading and installing Ghost v1.26.2
A SystemError occurred.

Message: Ghost v1.26.2 is not compatible with the current Node version. Your node version is 16.17.1, but Ghost v1.26.2 requires ^8.9.0 || ^10.13.0

Debug Information:
    OS: Ubuntu, v20.04.5 LTS
    Node Version: v16.17.1
    Ghost-CLI Version: 1.23.0
    Environment: development
    Command: 'ghost install local --v1'

… however, when I try to use Node v8.9.0 or v10.13.0, the Ghost CLI segfaults, because it needs a current version of Node.

I have tried to use a node version manager to set my system to use the old version, and then run ghost install local --v1 with Node v16.17.1 (n run 16.17.1 ghost install local --v1), without success.

Any insight would be greatly appreciated.


In order to install Ghost v1, you’ll need to install an older compatible version of Node.js and Ghost CLI:

There is a compatibility matrix here:


Thanks Hannah! That did it.

It could be useful to have a link to the node compatibility matrix somewhere in How to update from v0.x to v1.x and beyond - Ghost Developers; it never even crossed my mind that downgrading Ghost CLI would be the correct way to install V1 :)