Cannot upload / change theme, Casper doesn't work

Hi there,

i’m quite new in working with ghost, and i’m only trying to setup a small blog for my leisure. I’m running into a problem while trying to change from casper-Theme to anything else. First, after fresh installing i got (and still do) “Error 500” Casper Theme missing, though it sits nicely in the themes folder. I can’t upload another theme, everytime i get “Failed to read zip file” if i try to upload a theme via gui. If i just upload it via bash into the themes-folder, i don’t get to see it most of the time. Once i was able to see a bash-uploaded theme, but wasn’t able to activate it, only delete and download it.

My guess would be, permissions of the content-folder are wrong, but i couldn’t find anything regarding to “what user has to have permissions on the content-folder” or sth like that.

URL jd.uber.space
Version ghost 3.9.0
on a CentOS Shared Hosting, installed with npm and yarn, no root

Can you run ghost doctor? It should find any issues with your folder permissions :slight_smile:

Now that you say it…

  • if i run ghost doctor with my install parameters (–no-stack --no-setup-linux-user --no-setup-systemd --no-setup-nginx --no-setup-mysql --no-start --no-enable) there is no problem with folder permissions, but the usual “not ubuntu 16 or 18” and then the sudo pw prompt (which i don’t have)
  • if i run ghost doctor without the install parameters, just plain “ghost doctor” i get a red x instead of the green check at “checking folder permissions” and then “not ubuntu 16 or 18”. With verbose output i get

[09:38:38] → The directory /home/jd/ is not readable by other users on the system.
This can cause issues with the CLI, you must either make this directory readable by others or run ghost install in another location.

So i’ll just try that for now.

1 Like