Theme not available from git clone

I’m trying to develop a theme locally but I’m having issues with it displaying in the admin. My process has been so far:

ghost install local
cd into content/themes
git clone new theme into directory
ghost restart
Open Design section of admin to only see “Casper”

I can’t tell if it’s a caching issue or what, but there doesn’t appear to be any difference in the file structure vs. the Casper theme. Can anyone shed any light here?

Hi,
The steps you performed thats suppose to work…
There must be other issue… can you clone another theme & check ?

Yes I performed the same clone with the Starter theme and Massively and got the same result. Any way to debug what’s going on?

I am suspecting folder permission issue…
can you run ghost doctor & share the output of the command

This is with verbose output:

[16:42:55] Checking system Node.js version [started]
[16:42:55] Checking system Node.js version [completed]
[16:42:55] Checking current folder permissions [started]
[16:42:55] Checking current folder permissions [completed]
[16:42:55] Validating config [started]
[16:42:55] Validating config [completed]
[16:42:55] Checking memory availability [started]
[16:42:55] Checking memory availability [completed]
[16:42:55] Checking binary dependencies [started]
[16:42:55] Checking binary dependencies [completed]

OK, this seems to be an issue related to 3.29.0. When I installed 3.28.0 specifically the clone process worked. If I can track down the change I’ll submit an issue.

All seems okay

I will check this issue on 3.29.0 too

Hey @jhixson :wave:

The team are aware of the issue and we’re tracking it at https://github.com/TryGhost/Ghost/issues/12118. We hope to have a patch out soon, so watch this space :slightly_smiling_face:

1 Like

@jhixson We just released 3.29.1 which contains a fix for this issue - please update using Ghost-CLI :slightly_smiling_face:

Awesome! Thanks for the quick rollout.