Cannot use fields and include together in ghost api


#1

Using include param with fields doesn’t display include data, as seen in the screenshot below.

Using ghost PRO.


#2

custom_excerpt is not a valid value for include. Valid include values, for posts, are tags, authors, author (deprecated). If you want to get custom_excerpt too try add it into the fields parameter.


#3

@HauntedThemes doesn’t seem to work, same issue.


#4

This seems to be a bug. I remember that there was an issue on GitHub about this but I can’t find it. The only solution is to remove the fields parameter. If you leave only include: tags and formats: plaintext it should work. The problem is that you will get all the fields and not be able to select them with fields parameter.