Can't figure out how to setup email


#1

If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you. Try to always mention:

  • What’s your URL? https://intheair.aersure.com
  • What version of Ghost are you using? 2.6.1
  • What configuration? Self Hosted
  • What browser? Chrome
  • What errors or information do you see in the console? Failed to send email. Reason: connect ETIMEDOUT 74.125.24.109:465
  • What steps could someone else take to reproduce the issue you’re having? Tried to change the configuration file but to no avail.

I am using a Gmail account as the SMTP server.


#2

Could there be something to do with the following error when restarting ghost?

  1. Validating config

Error detected in the production configuration.

Message: Config file is not valid JSON


#3

Yep, run your config through a JSON validator (for example, https://jsonlint.com/) and make sure it passes :slight_smile:


#4

google translate


#7

I’ve followed your steps but receive the following error:

Request was rejected due to server error

This is my file:

"mail": {
		"from": "<noreply@aersure.com>",
		"transport": "SMTP",
		"options": {
			"service": "Gmail",
			"host": "smtp.gmail.com",
			"port": 465,
			"secureConnection": true,
			"auth": {
				"user": "noreply@aersure.com",
				"pass": "password"
			},

#8

I found out that Digital Ocean, blocks all SMTP ports. Any way to go around this? I also signed up for Mailgun and still can’t send out emails.


#9

I use aliyun,it’s dashboard can open port 465/465 for output direction