Email failed to send - please verify your email settings 📧 / Email service is currently unavailable - please try again

Hi everyone,
Ubuntu 18.04
Ghost Version 3.32.2
Environment production
Database mysql
Mail SMTP
Url private

This is the json:

"mail": {
  "transport": "SMTP",
  "options": {
    "service": "Mailgun",
    "host": "smtp.eu.mailgun.org",
    "port": 465,
    "secureConnection": true,
    "auth": {
      "user": "postmaster@mg.******.it",
      "pass": "************************************"
    }
  }
},

I have updated and confirmed the email newsletter from the labs section.
I entered noreply@mydomain.it (the email noreply really exists).

The test newsletter email is working correctly.

What could be the problem?

2 Likes

I updated to the latest version 3.33.0, the problem persists.

1 Like

I have the same problem, I was using Ghost 3.19.0 and upgraded to 3.33.0 and the error continues

I haven’t been able to fix it yet

1 Like

I contacted Mailgun support to check if there was any restriction or block on my account, I was informed that it was not.

I checked all the Ghost settings again and they are all ok, the registration emails, login, invitations from new authors, are being sent normally, only the newsletter that is not sent.

I’m using Ghost 3.33.0, on a DigitalOcean VPS running Ubuntu 18.04 (LTS) x64.

2 Likes

I have a similar problem. When testing the signin/signup forms this same error keeps showing up. I assume the error would be the same if I sent emails with Ghost.

My setup is exactly the same.

Which Mailgun API key are you using? I’m using the private one, I don’t have any luck with the public one.

2 Likes

I’m also using Mailgun’s private key, but yesterday, mysteriously, Ghost started sending the Newsletter again, without me doing anything.

3 Likes

I tried to enter the API KEY again, the problem persists

1 Like

I updated to the latest version 3.34.0 , the problem persists.

1 Like

I can’t afford this so I decided to switch to GhostPro for this month. An input from team Ghost would be great to see where the problems is…

I updated my Ghost local installation and the problem also didn’t go away.

I hope, but I am sure, that the Ghost team is investigating the problem, so they have no answer yet.

1 Like

I updated to the latest version 3.34.1 , the problem persists.

1 Like

Will like this miracle to happen to me also!

Mailgun is asking me to provide them error log. I am not a techie, how do I do that?

1 Like

Are they requesting error logging from Mailgun or Ghost? If it’s the MailGun error log, just access the side panel on your dashboard.

The Ghost log is already in the content/logs folder.

Mailgun wants ghost error logs. Do you know how to find ghost error logs from the control panel. I have no idea how to access content/log

The ghost.org documentation is written by a tech lead. Don’t understand it.

When I try to access my content.log

I am told that as a root user I cannot access my log. This is issue with digital ocean install only link

When I try to create a new user, I am getting some syntax error. screenshot

Anyone can tell me why I am not able to create a new user?

Following this, I also have this problem

Remove the characters '<' and '>’ and enter only your username: adduser manoj.

After you add the user and follow the Ghost documentation step by step, just access via ssh the directory /var/www/your_site/content/logs.

Inside the directory if you type the command ls to see the available log files, it will definitely look like https_your_site_production.error.log and https_your_site_production.log

No there is simpler way, but I am unable to get it. I don’t understand linux commands

When you use DO one-click install in order to manipulate anything you should see a prompt to:

sudo -i -u ghost-mgr

Providing/assuming you set it up correctly I suppose, but this should let you do what you’re trying to do by getting you off the root.

1 Like