Catch 22 : upgrading a ghost install that was never installed by ghost-cli

I’m currently running Ghost 5.44 through the yunohost webpanel. I’d like to update to the latest version but I have to use ghost-cli to update.

Every time I try to run a ghost command there is this error message :

run ‘ghost command’ within a folder where Ghost was installed whit Ghost-CLI

Is it risky to run ghost install ?

should I uninstall/reinstall ?

has anyone encountered that snag before me ?

thanks in advance

You should enter the folder Ghost is installed in and then do this

ghost backup
ghost update

I’ve tried in /var/www, var/www/ghost/, var/www/ghost/ghost and var/www/ghost/ghost [something]/version/5.44.0.

every time the same error message about using that command in a folder where ghost was installed using ghost-cli but…

I’m 100% sure I never installed ghost using ghost-cli

Please confirm where Ghost is installed, including the user who has permissions to run. Alternatively, you can try ghost ls from any folder.

I did.

Error message says “no installed ghost instances found” - and yet there is one.

I’ve taken a very quick look at Yunohist and it’s clear Ghost is packaged, and should not be updated in the usual way.

It looks like you should do something like this.

sudo yunohost app upgrade ghost -u --debug