Not able to update ghost on DigitalOcean


#1

image
I am using DigitalOcean’s One-Click droplets to host my blog but recently I tried to issue an update command and it shows the following message. So will DigitalOcean’s OneClick Droplet system automatically update my Ghost in the future or is there any other solution to this problem?

  • My Blog link
  • I am using Ubuntu 18.04 with Ghost on Digital Ocean

#2

The error message is telling you that you’re not in the folder where Ghost was installed. The command has to be issued from the Ghost folder as it’s perfectly legitimate to have more than one ghost install.


#3

@staticpixel check in the current directory where you are running that commands with “pwd” and check if it’s correct. If not, go to the folder where you installed Ghost and then try again


#4

But during installation I have not gone to any other folder. I followed the instructions as was given here and accordingly I have not gone into any other folder. How do I know wher Ghost was installed if didn’t go into any folder in the first place?!


#5

image
@daburix This is what it shows. How to navigate to the correct one? I have no idea.


#6

@staticpixel maybe in /var/www/ghost/ ?


#7

@daburix Thank You very much! Problem solved! :hugs:


#8

@staticpixel cool! welcome :slight_smile:


#9

ghost ls Lists all of your ghost installs and their locations. The same messaging that tells you about using sudo -i -u ghost-mgr should also be telling you where Ghost was installed.


closed #10

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.