Changing Config URL Turned Blog Private


#1

I am running Ghost on a reverse proxy where my main website is hosted on an AWS server and then a Ghost server on DigitalOcean. I have an nginx config that has a location block /blog with a proxy_pass to my Ghost Server IP address http://xxx.xxx.xx.xx; and I originally set up the ghost url as http://xxx.xxx.xx.xx/blog, but I noticed canonicals and other links were not set with www.my-site.com/blog, but xxx.xxx.xx.xx/blog. As a result I tried to update the url to https://www.my-site.com/blog, but this now brings me to https://www.my-site.com/blog/private/?r=%2F. I don’t know how my blog was set to private, but I can’t figure out how to fix this and revert it back to public. I tired changing the url once more to http://www.my-site.com/blog and nothing changed. Can anyone provide help on both how to set my blog to public and fix the reverse proxy setup?


#2

Hey there :wave:

Private mode and url config aren’t really related, so you can set your URL back to what you want it to be.

What version of Ghost are you on? There was a bug relating to private mode in an earlier version that has now been fixed - updating to the latest version of Ghost might fix your issue.

If it doesn’t, you can disable private mode in the Admin panel (https://your.site/blog/ghost) by clicking the general link in the sidebar, scrolling to the bottom, unchecking the Make this site private checkbox and clicking save (scroll to the top, it’s at the top right).


#3

Thanks for your answer! So I have always had that setting unchecked, but for some reason when I change my url config and reverse proxy it must have triggered something to enable it despite the checkbox being unmarked when I check the setting. I clicked save settings as you advised anyway and that fixed the problem. Seems like a strange bug. I’m on version 2.16.3.


#4

2.16.3

:warning: 2.16.3 contains a critical bug that may result in your site appearing in private mode. :warning:
Please use 2.16.4 or later instead. (Release Page)

I would suggest you upgrade to 2.18.1 since there have been a couple of pretty helpful changes in the last few releases :slight_smile: