Changing URL to HTTPS causes redirect to localhost

If you’re looking for help, please provide information about your environment. If you delete this template and don’t provide any information, your topic will be automatically closed.

If you aren’t running the latest version of Ghost, the first thing we’ll ask you to do is update to the latest version of Ghost.

  • What’s your URL?
  • What version of Ghost are you using? 5.38


  • How was Ghost installed and configured? Installed on a lightsail server using bitnami
  • What Node version, database, OS & browser are you using? On Safari
  • What errors or information do you see in the console? GET requests return 302
  • What steps could someone else take to reproduce the issue you’re having? Change the URL from HTTP to https in ghost config.

I changed the URL from HTTP to HTTPS in ghost config. After that, going to my site redirects to .

I did what was asked to do here, Force HTTPS redirection with Apache.

The problem wasn’t resolved. Bug: Setting url: to https in config.js causes a redirect loop · Issue #2796 · TryGhost/Ghost · GitHub I found this which seems to solve the problem for others but not me. I added the line RequestHeader set X-Forwarded-Proto "https" in opt/bitnami/apache/conf/bitnami/bitnami.conf and

It did not work. Did I correctly applied the solution? And what should I do from here. Thank you.