Connect ECONNREFUSED 127.0.0.1:2369

I began trying to spin up a second instance of ghost on my same digital ocean droplet, and in the process ended up deciding to uninstall ghost, node, npm, etc. and reinstall. (I knew this would drop my existing Ghost instance, but figured I could just run ghost start again)

Now I’m not able to get my old instance OR my new instance running. I CAN get it to spin up with ghost run, but ghost start doesn’t work at all. Below you can see my error, which is saying it can’t connect to the ghost port 2369. I’ve double checked the config and my NGINX .conf file, both of which are pointing to port 2369.

Since I’m not having any luck even with my brand new ghost install, I don’t think trashing this instance and transferring the data on a new instance would even work. At this point, I’m all out of ideas :cry:

- What’s your URL?
https://coursework.vschool.io

- What version of Ghost are you using?
1.25.4

- What configuration?
I’m not sure what this means. Here’s the debug information that spit out:

Debug Information:
    OS: Ubuntu, v18.04.3 LTS
    Node Version: v12.14.1
    Ghost Version: 1.25.4
    Ghost-CLI Version: 1.13.1
    Environment: production
    Command: 'ghost start'

- What browser?
Chrome

- What errors or information do you see in the console?
Here’s what initially logs:

+ sudo systemctl is-active ghost_coursework-vschool-io
+ sudo systemctl reset-failed ghost_coursework-vschool-io
✔ Ensuring user is not logged in as ghost user
✔ Checking if logged in user is directory owner
✔ Checking current folder permissions
+ sudo systemctl is-active ghost_coursework-vschool-io
✔ Validating config
✔ Checking folder permissions
✔ Checking file permissions
✔ Checking content folder ownership
✔ Checking memory availability
✔ Checking binary dependencies
+ sudo systemctl start ghost_coursework-vschool-io
+ sudo systemctl stop ghost_coursework-vschool-io
✖ Starting Ghost: coursework-vschool-io
A GhostError occurred.

Message: Ghost did not start.
Suggestion: journalctl -u ghost_coursework-vschool-io -n 50

Debug Information:
    OS: Ubuntu, v18.04.3 LTS
    Node Version: v12.14.1
    Ghost Version: 1.25.4
    Ghost-CLI Version: 1.13.1
    Environment: production
    Command: 'ghost start'

Additional log info available in: /home/bob/.ghost/logs/ghost-cli-debug-2020-01-31T16_22_05_811Z.log

Try running ghost doctor to check your system for known issues.

You can always refer to https://ghost.org/docs/api/ghost-cli/ for troubleshooting.

Here’s the result of running the journalctl command:

Hint: You are currently not seeing messages from other users and the system.
      Users in groups 'adm', 'systemd-journal' can see all messages.
      Pass -q to turn off this notice.
-- Logs begin at Wed 2019-12-11 17:20:00 UTC, end at Fri 2020-01-31 07:40:38 UTC. --
-- No entries --

Here’s what logs to the ghost logs:

Debug Information:
    OS: Ubuntu, v18.04.3 LTS
    Node Version: v12.14.1
    Ghost Version: 1.25.4
    Ghost-CLI Version: 1.13.1
    Environment: production
    Command: 'ghost start'
Message: Ghost did not start.
Suggestion: journalctl -u ghost_coursework-vschool-io -n 50
Stack: Error: Ghost did not start.
    at /usr/lib/node_modules/ghost-cli/lib/utils/port-polling.js:150:28
    at processTicksAndRejections (internal/process/task_queues.js:94:5)

Original Error Message:
Message: connect ECONNREFUSED 127.0.0.1:2369
Stack: Error: connect ECONNREFUSED 127.0.0.1:2369
    at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1134:16)

- What steps could someone else take to reproduce the issue you’re having?
Try to start my ghost instance :sweat_smile:

I think the problem had to do something with having one Ghost instance on 1.25.x and another on 3.4.0. Maybe something with the ghost-cli package not working the same with both? (Maybe not though).

Either way, I ended up spinning up a brand new ghost instance and using the same database as the original, older version of Ghost. Then I deleted the old Ghost instance. Made a few new tweaks to the Casper theme that I had made on the old one, and we’re up and running again.