Dawn Theme; "root URL" getting HTTP 400


I was running the substation theme (https://superthemes.co), and after upgrading to Ghost 4.0, want to start simply running Dawn.

So, I downloaded the theme, activated it, and the “root” url (https://parent.bar) gives me a 400 error.

The exact error is:

Missing template for home.hbs for route “/”.

I suspect this is a problem with routes.yaml, but for the life of me, can’t figure out how that file works (so beginner tips welcome).

If I move home.hbs from the original theme’s directory, it displays and all works, but… what I really want is the Dawn default home page when someone goes to that URL.

Why is the default Dawn Theme not working with the plain-old root directory? Why is it looking for a file that’s not there? Am I asking the wrong questions?

By the way, Superthemes is great, I’m just taking “one step back, to go two steps forward”.

I’m going to leave my site in error 400 mode (with Dawn active) so if someone needs to see it to help, you can see the problem I’m seeing.

Thanks much!


Once you change the theme, you must re-upload the route.yalm follwing because the old theme route.yalm will stay forever and conflict with new theme (evenly it is not be deleted, the fact, it stays forever on your storage).

So, the solution is simple, reupload the route.yalm on Dawn theme folder (unzip on your desktop) to Ghost admin.

1 Like


Thank you. This was the answer.

I thought labs went away in 4.0… they haven’t. They’re under settings, and there’s still a button to upload routes.yaml. (I wrote this in case anyone comes on this thread in the future.)

Once I uploaded the routes.yaml from the theme directory using settings/labs, it worked just fine.

Have a nice evening/day,