Enable Cloudflare Proxy on Ghost blog


#1

If you’re looking for some help, it’s important to provide as much context as possible so that people are able to assist you. Try to always mention:

  • What’s your URL? This is the easiest way for others to debug your issue

scrumbug dot ghost dot io / jessehouwing dot net

  • What version of Ghost are you using?

Ghost Pro

  • What configuration?

With Custom Domain

  • What browser?

N/A

  • What errors or information do you see in the console?

  • What I am trying to accomplish

I want to add a couple of security headers so I don’t look like a security inapt blogger and to protect my readers. Integrate Report-Uri and a few other nifty things.

I think I could go about it as follows:

  • Setup ghost dot jessehouwing dot net and configure Ghostio to use that
  • Setup jessehouwing dot net to be a CNAME for ghost dot jessehouwing dot net and enable Page Rules and Workers
  • Setup Cloudflare Workers to inject the security headers I want

But I’d rather just turn jessehouwing dot net into a proxiable domain so I can do this without extra externally visible records.

PS the no more than 2 domain rule is pretty stupid for a help site on a hosting/blogging platform.


#2

This is what I see in the Cloudflare console:


#3

For Ghost Pro you’re better off writing directly to support@ghost.org and the team will help you directly.


#4

I did. They’re having weekend. Was hoping to get a solution before Monday.


#5

Cloudflare does not support custom workers or headers on Ghost(Pro) - this is a limitation in Cloudflare.

Actually you can redirect as many domains as you want to whatever your primary domain is, there’s absolutely no reason to have more than one domain configured for any site - search engines would ignore all but one of them anyway.


#6