Unable to get blog working with Cloudflare


I’m not able to get Ghost and Cloudflare working together.

I’ve done a stock 1-click Ghost install via Digital Ocean. I’m using Cloudflare to manage DNS.

When I use the Cloudflare Proxy (as below)

I get this issue (see below)

And everything goes back to normal as soon as I revert back to the DNS only option.

Obviously I would like to use Cloudflare given that I’m on a cheap DO droplet - so would appreciate any help

Your site is working for me. Have you disabled Cloudflare proxy?

The errors suggest a redirection loop, so be sure to clear your browser and cookies.

If this doesn’t resolve the problem, describe the SSL settings in Cloudflare, and share the Nginx config.

Thanks for checking!

Just got it working.

The fix is to set SSL (from within Cloudflare) to “FULL”

The default is “Flexible” - which causes the above error.


Yes, Full is necessary. I also use authenticated pull, and Cloudflare issued certificates.

1 Like