Error 500 on my ghost admin panel


I am getting a 500 error when i login to my ghost admin panel. I am able to do all the work whatsoever. Able to create posts etc, not able to use send mail functionality( that’s another issue though), but admin panel shows 500 each time. Please help. My details are as below:

  • Using Ghost Version 3.15.3
  • Running it on AWS
  • Getting this on Google chrome and safari
  • Console Log : Mixed Content: The page at '' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint ''. This request has been blocked; the content must be served over HTTPS.

That’s really weird :confused:

Based on the console statement, it looks like your ghost url is incorrectly set (it uses http instead of https), but when looking at your site settings (, everything looks fine. Just to be safe, can you check that your url is

So, I managed to resolve it by some config changes in the apache virtualhost file. Everything works fine now.
But, I get a different issue on console. I don’t really know if that could be an issue, may be a warning.
When I do sudo /opt/bitnami/ restart I get below response

You can see everything runs ok, just those syntax errors. Could you assist, how I can get rid of these ?

I don’t have much experience with httpd so I can’t say much, but it looks like you might have a typo in your apache conf

Ok. My site is working without any issues. May be I will let it run till I get any issues :smiley:

1 Like