Cloudflare SSL causing 500 error in admin panel

Hi

I’ve installed the latest version of Ghost on a Digital Ocean droplet, all was working fine on the backend of the system.

I have now installed the Cloudflare SSL by allowing Cloudflare to take control of my name servers.

I have now logged into the backend of the system, everything works however I no longer see a preview of my website, If I am logged in and click visit website I just see the 500 error page with the cactus.

Why has installing the Cloudflare SSL caused this problem and is there anyone that could offer some assistance in how to resolve it so I can see my website when I’m logged in.

Many thanks

Bypass the cache for ghost admin dashboard

1 Like

In addition to the above, If you are familiar with the developer tools in your browser it may offer more insight.

Worth noting, by pointing your DNS to Cloudflare you aren’t ‘installing’ an SSL certificate as such. You are proxying traffic to your site via Cloudflare. Visitors will connect to Cloudflare (and receive the SSL certificate from there) and then Cloudflare connects to your server (aka origin). Do you have an SSL cert also installed on the origin? If so, what SSL mode are you using? You can see this in the SSL/TLS tab (Flexible, Full, etc). Ideally you want an SSL cert at your origin, even if its self signed, for end to end SSL. However since you can load the admin part of the site OK this may not be the issue.

Check the cache article and ssl settings, and dig into developer tools when trying the site preview. Can you reach the site homepage directly without error?