Error Setting a Post to a Specific Tier


Awesome work on Tiers, even in Beta—so far, was able to do what I need, except one issue: when I try to publish a post to (for example) Gold members only, it gives me the following error.

I searched the Forum but couldn’t find anything. Am I the only one with this Error?

I’m using the default Casper 4.1.1 on Ghost(Pro)


I’m getting the same error here, though this is actually with a page rather than a post. From the screenshot, it looks like yours is actually a page as well. As a test, I tried this with an old post and a new post and got no error with either, so it seems to happen with pages only.

The page error first appears when I try to set Page Access to either of my member tiers. Including it here, so it’s searchable for others:

Internal server error, cannot edit page. Query Error: unexpected character in filter at char 1 filter ^ Expecting 'LPAREN', 'PROP', got 'LITERAL'

EDIT: Also should add that for me the error only appeared when changing access on an existing page. I tested this with a new page and got no error. Spoke too soon. The error appeared when I tried to save the new page.

I think, you’re right, @brooklet !

The posts seem to work, and the pages don’t—for me, too.

It’s a pity, as I’d love to be able to write different Welcome! pages based on tiers—Silver, Gold, Platinum—as this is where the differences lie and it would be good to let the members understand the differences, based on which tier they belong to.

But, for now, I’ll settle for one Welcome! page for all paid tiers + tier-differentiated posts.

Thank you! :pray:🙇‍♂

Submitted a bug report (Error Setting Page Access to Tiers · Issue #13704 · TryGhost/Ghost · GitHub), so hopefully someone is able to solve it soon!

1 Like

Just a heads up that the fix for this was released today with 4.22.0!