Failed yarn dev + gulp


#1

Hi guys,

I am customizing a Casper theme and I can’t get it zipped. Gulp just fails no matter what I do. Here are the logs:

$ yarn dev
yarn run v1.9.4
$ gulp

assert.js:85
  throw new assert.AssertionError({
  ^
AssertionError: Task function must be specified
    at Gulp.set [as _setTask] (/home/javier/opt/ghost/content/themes/Casper/node_modules/undertaker/lib/set-task.js:10:3)
    at Gulp.task (/home/javier/opt/ghost/content/themes/Casper/node_modules/undertaker/lib/task.js:13:8)
    at Object.<anonymous> (/home/javier/opt/ghost/content/themes/Casper/gulpfile.js:27:6)
    at Module._compile (module.js:556:32)
    at Object.Module._extensions..js (module.js:565:10)
    at Module.load (module.js:473:32)
    at tryModuleLoad (module.js:432:12)
    at Function.Module._load (module.js:424:3)
    at Module.require (module.js:483:17)
    at require (internal/module.js:20:19)
    at execute (/home/javier/opt/ghost/content/themes/Casper/node_modules/gulp/node_modules/gulp-cli/lib/versioned/^4.0.0-alpha.2/index.js:36:18)
    at Liftoff.handleArguments (/home/javier/opt/ghost/content/themes/Casper/node_modules/gulp/node_modules/gulp-cli/index.js:175:63)
    at Liftoff.execute (/home/javier/opt/ghost/content/themes/Casper/node_modules/liftoff/index.js:203:12)
    at module.exports (/home/javier/opt/ghost/content/themes/Casper/node_modules/flagged-respawn/index.js:51:3)
    at Liftoff.<anonymous> (/home/javier/opt/ghost/content/themes/Casper/node_modules/liftoff/index.js:195:5)
    at /home/javier/opt/ghost/content/themes/Casper/node_modules/liftoff/index.js:165:9
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

I synced my gulpfile.js to the latest in case anything was broken in the previous version. I don’t see what’s wrong int here. Any ideas?

Thanks


#2

Run yarn install and then yarn dev :slightly_smiling_face:


#3

Yeah I was doing so but I was getting this error with yarn dev…

So I tried reinstalling ghost in another folder, resynced gulpfile.js and package.json and then it worked without problems… I think I was having some weird setup happening with my ghost installation.

Now it works just fine :slight_smile:


#4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.