File uploads - Changelog

Following audio and video cards, now you can add downloadable files to your posts in Ghost. File uploads can be used to share multiple types of content with your audience, for example:

  • Share bonus downloadable content with paid members
  • Include swipe files or templates for your readers to download
  • Give out photography or videography presets/filters
  • Grow your audience with a lead magnet
  • Give members access to download an ebook you've created

Files display in your content with a custom name and caption, like this:

Merry Cardmas — From the Ghost team🎄
A Cardmas Card from our team to yours
Cardmas 2021.pdf
902 KB

And that's all there is to it!

File upload cards support files of up to 50mb depending on your Ghost(Pro) plan, and accept any filetype.
See all 12 days of Cardmas →

Terrific, bravo, thank you -

I made a small observation: when I upload a file or a document, the file name propagates to the card text. The downloaded file has the same name as the one I uploaded into Ghost. But if I upload a file in Cyrillic letters (ex Крузенштерн.jpg) the file name doesn’t propagate, and the downloaded file is named -------.jpg.

Wouldn’t call it a bug really, but maybe something useful to be aware of?

Would supporting a caption for the card (as in photos and videos) be supported only in the theme, or would it need other support from Ghost itself? Though off-topic, related is a caption for the audio card.

I self-host ghost and uploaded a video that is greater than 50 MB. Got the message:

Screen Shot 2021-12-29 at 6.33.18 AM

How do I change the settings to allow for greater than 50 MB video upload?

Thank you.

If you run it with an nginx setup, you need to add the following line to your ngninx.conf file (usually located in /etc/nginx/nginx.conf) under the http section

        client_max_body_size 100M;

Or (as the official documentation suggests), use this in your nginx.conf:

client_max_body_size 50m;

It didn’t work for me.

Screen Shot 2021-12-29 at 12.38.48 PM

$ sudo nano /etc/nginx/nginx.conf
$ sudo service nginx restart
$ cd /var/www/ && ghost restart

Got the same message.
Tried 500M and 500m.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.