Fresh install 5.49.3 - website connection has timed out

Hi I have created a new oracle cloud vm and run updates/upgrade. Followed the official Ghost install guide

URL: Ghost Admin
Ghost: 5.49.3
OS: Ubuntu 20.04
Nginx / MySQL 8
I have tried using Google chrome and Firefox, I have checked my A record is pointing to my cloud ip address,When I run Ghost Doctor there are no errors, I have checked firewall settings which allow https/http

  • sudo systemctl is-active ghost_tech-techiemike-com
    │ Name │ Location │ Version │ Status │ URL │ Port │ Process Manager │
    │ tech-techiemike-com │ /var/www/ghost │ 5.49.3 │ running (production) │ │ 2368 │ systemd │

:heavy_check_mark: Checking system Node.js version - found v16.20.0
:heavy_check_mark: Checking logged in user
:heavy_check_mark: Ensuring user is not logged in as ghost user
:heavy_check_mark: Checking if logged in user is directory owner
:heavy_check_mark: Checking current folder permissions
:heavy_check_mark: Checking system compatibility
:heavy_check_mark: Checking for a MySQL installation

  • sudo systemctl is-active ghost_tech-techiemike-com
    Instance is currently running
    :information_source: Validating config [skipped]
    :heavy_check_mark: Checking folder permissions
    :heavy_check_mark: Checking file permissions
    :heavy_check_mark: Checking content folder ownership
    :heavy_check_mark: Checking memory availability
    :heavy_check_mark: Checking binary dependencies
    :heavy_check_mark: Checking free space
    :heavy_check_mark: Checking systemd unit file
    :heavy_check_mark: Checking systemd node version - found v16.20.0

I have tried rebooting the server and reloading the page same error, nginx default page shows fine, any idea why I cannot access the page? or what else I could check?

It looks like Ghost is running on port 2368. Does this correspond to the sites-available config for Nginx? Likewise, it looks like you’re not using SSL.

Thanks for your reply, I forgot to open https

1 Like