Gallery not working on local install, but works on server

  • What’s your URL?
  • What version of Ghost are you using?
  • How was Ghost installed and configured?
    Local install
  • What Node version, database, OS & browser are you using?
    Node v18.13.0, Firefox, Windows 10
  • What errors or information do you see in the console?
  • What steps could someone else take to reproduce the issue you’re having?
    Upload images as a gallery in a post on a local install


Something has been puzzling me lately.

I’m trying to understand why the galleries can’t get displayed properly on my local install.
Because it works without problem on my self-hosted website using the exact same theme.

When I’m working on my local install and want to create a gallery in a post, it works within the editor:

But this is how it gets displayed on the page when I click preview and/or publish the article:

As I said, I’m using the exact same theme on both my local install and my server. What am I missing here?

Thanks for your help.

This is a known bug with how card assets are (not) built on windows. The workaround is to host ghost within wsl.

1 Like

Thanks, Cathy, I didn’t know about this. Guess I’ll have to live with it for now!

Setting up WSL isn’t too hard - there was about an hour of waiting for the (huge) download and install to finish, but then it was not hard at all to get Ghost set up within WSL.

1 Like