Ghost 2.0 Docker: links point at localhost:2368


#1

Upgraded to Ghost 2.0 on Docker Alpine on Friday. The links point at http://localhost:2368. Sure they did not when i was running ghost:1-alpine in Docker. How can I correct this so the links point at my domain name? Tried passing in environment variables when starting up container but no joy.

Thanks

Phil


#2

I will admit I just started paying with Ghost this evening as a way to play around with Docker some more; so I may not be doing everything the most ideal way but… I found the Ghost Docker a bit under documented and that kind of pushed more to explore whats going on a bit more.

Oh you could forget about traefik bits.

the docker-compose file:

ghost:
   image: ghost:2-alpine
   container_name: ghost
   restart: always
   volumes:
     - /srv/docker/ghost/data:/var/lib/ghost/content
   environment:
     - url=https://ghost.${DOMAINNAME}
   networks:
     - traefik_proxy
   labels:
     - "traefik.enable=true"
     - "traefik.backend=ghost"
     - "traefik.frontend.rule=Host:ghost.${DOMAINNAME}"  
     - "traefik.port=2368"
     - "traefik.docker.network=traefik_proxy"

`

Also to note, I have an .env file which has my DOMAINNAME defined.


#3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.