Remove port 80 in links

I’m using latest ghost in docker and a reverse proxy with ssl.

In the config.production.json, i had to remove :80 to keep the title banner (linking to homepage), from using port 80. I also cannot use the “view site” in the editor, i assume due to it trying to force use port 80 all the time.

In test news letters that I send and in random locations, it’s still trying to use port 80 in the links.
Is there a way that i can completely disable it from trying to use a specific port and just rely on using the domain?

As an example, it’s appending port 80 to all labels.

I’m hoping there’s some other config file that i can’t find

mariadb
chromium
Docker: Docker Hub

Did you restart Ghost / the container after updating the URL to not include :80? Also, since it’s docker, are you overriding the URL with your env variables?

thanks for the reply :slight_smile:

Yes, i’ve restarted it.
It’s mapped to local port 2368 in docker.

There is a variable to choose http/https. This is set as https.
The application url variable points directly to the site without specifying http/https. (blog.sparkrouter.com)

Do other installations of ghost append ports to urls by default?

If not, i’ll tinker around with the docker-compose perhaps

No, most installs don’t have port appended. I’d recommend just using something like nginx to wrap SSL around the ghost install. It’s likely some setting that needs to be updated. Now if you have links in the body of the post you may need to change those manually depending on how they were generated.

AH! i got it. Ironically, it was the variable to select https. I swapped it back around to http and it seems to work fine and it removed the appended port 80’s all over. Just can’t reach the site locally, but that’s a whole other bag of worms i don’t want to dig into just yet :stuck_out_tongue:

For anyone else using unraid as a docker host and using bitnami’s ghost image ↓