Ghost CLI setup adding user to MariaDB fail


#1

Hi,
I had my Ghost up-and-running on my own server (Debian, v9.4) and I haven’t done updates since more than a year (prob. two years…).
I went for the full update following the install instructions and got stuck with the database ghost user. The error is:
Message: ER_NOT_SUPPORTED_AUTH_MODE: Client does not support authentication protocol requested by server; consider upgrading MariaDB client
I obviously have an up-to-date MariaDB (Server version: 10.1.26-MariaDB-0+deb9u1 Debian 9.1) and I have the following users:
MariaDB [(none)]> SELECT User, Host, Password FROM mysql.user;
±------±----------±------------------------------------------+
| User | Host | Password |
±------±----------±------------------------------------------+
| root | localhost | |
| ghost | localhost | *44F… |
±------±----------±------------------------------------------+

This is where ghost setup fails:

? Do you wish to set up “ghost” mysql user? Yes
â Setting up “ghost” mysql user
A CliError occurred.

Message: Error trying to connect to the MySQL database.
Help: You can run ghost config to re-enter the correct credentials. Alternatively you can run ghost setup again.

Debug Information:
OS: Debian, v9.4
Node Version: v6.14.2
Ghost-CLI Version: 1.7.3
Environment: production
Command: ‘ghost setup’

Any clue how to get around this?

Cheers,
Helder


#2

Does the troubleshooting guide in the docs help?


#3

Hi,
thanks, that did indeed put me on the right track. I did not see that suggestion. Resetting the password was a bit more complicated but somehow at the end it worked. So that did the trick.
Thanks again…


#4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.