Ghost cli shows errors after latest update to 1.11.0

Hello everyone,

trying to get my head around the latest update to ghost CLI, as far as I can tell I am running the latest ghost 2.10.x. My blog works fine but I am no longer able to run my status or update commands as they’re throwing the error below. I’ve tried to find out if anyone else was having similar issues, but either my search skills are poor or I’ve found myself in this unique predicament :slight_smile:
Happy to provide more context if need be. Thank you in advance for looking into this.

ghost-mgr@stig:/var/www/ghost$ npm install ghost-cli -g

/usr/bin/ghost -> /usr/lib/node_modules/ghost-cli/bin/ghost
└── ghost-cli@1.11.0

ghost-mgr@stig:/var/www/ghost$ ghost status
static async _run(commandName, argv = {}, extensions) {

SyntaxError: Unexpected identifier
at createScript (vm.js:56:10)
at Object.runInThisContext (vm.js:97:10)
at Module._compile (module.js:549:28)
at Object.Module._extensions…js (module.js:586:10)
at Module.load (module.js:494:32)
at tryModuleLoad (module.js:453:12)
at Function.Module._load (module.js:445:3)
at Module.require (module.js:504:17)
at require (internal/module.js:20:19)
at Object. (/usr/lib/node_modules/ghost-cli/lib/bootstrap.js:6:17)

Please share the following information.

Ghost-CLI version:
Ghost version:
Node version:
Nodejs version :

Node version 6 deprecated. Please make sure you are using node 10.x and reinstall the ghost-cli again


I realize this is dumb but can you share or point me to a guide that describes how I can do that?
I didn’t even know the version I was using was deprecated.
Many thanks for your support so far.

It’s all here :slight_smile: See this section about node:

You can google these easily :slight_smile:
Have fun!

Yes, sir, once you know what you’re going to google for then absolutely, it is easy as with everything else :slight_smile: Thanks, this is now solved, all I had to do as it turned out was these simple steps (as root):

curl -sL | sudo -E bash
apt-get install -y nodejs


root@stig:~# nodejs --version
npm --version


Glad it’s now working on your side!

Google idea install node version install ghost on ubuntu

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.