Problem upgrading to ghost-cli 1.13.1

Hi,

I’m trying to create a new ghost site on my linode vps. When I ran ghost install I got the following error message:

Message: Ghost v3.0.3 is not compatible with this version of the CLI.

Debug Information:
    OS: Ubuntu, v16.04
    Node Version: v10.13.0
    Ghost-CLI Version: 1.9.9
    Environment: production
    Command: 'ghost install'

So when I tried to update the cli: npm install -g ghost-cli@latest. I get:

/home/ghostex/.nvm/versions/node/v10.13.0/bin/ghost -> /home/ghostex/.nvm/versions/node/v10.13.0/lib/node_modules/ghost-cli/bin/ghost
+ ghost-cli@1.13.1

But ghost -v is telling me the cli version is still the same:
Ghost-CLI version: 1.9.9
Ghost version: 2.10.1

Not sure if it helps, but running which ghost shows the following:
/home/ghostex/.nvm/versions/node/v10.13.0/bin/ghost

I’ve seen a similar thread here: Updating Ghost CLI to get Ghost v3 but I wasn’t sure if I should follow Fabien’s advice on running alias ghost or changing the PATH.

Appreciate it if someone could point me to the right direction.

thanks in advance!

Hi David, if you are running NVM, you have to remove ghost-cli in node_modules from the different versions of nodejs.

In my case, I have had the same problem. I removed all ghost-cli from node versions 8, 10 and 12. But I had still a none NVM node installed.

So I removed as well and then I choose the node version recommended (10 LTS) install ghost-cli as global and it works.

(Copied from my post from the related thread)
I had to delete the ghost cmd in /usr/local/bin/ and the ghost-cli module from /usr/local/lib/node_modules . Then I had version 1.13.* working.