Ghost Droplet with Digital Ocean Not Working (Ghost Running, but Address not Found in Browser)

Hi All,

I recently tried to setup Ghost with Digital Ocean. It seems my installation was successful as “ghost ls” and “ghost start” indicate everything is running and operating normally. When I try to navigate to the website I am told nothing is found at the address. I set the A record in Digital Ocean and with my domain provider.

What am I doing wrong?



  • Digital Ocean Droplet
  • Most recent version for all
  • No errors it says ghost is running
  • Try installing Ghost using digital ocean droplet.

Your DNS seems to be fine, but Nginx isn’t returning anything. Make sure your Nginx config is proxying the correct port for Ghost.

I tried installing nginx again in the ghost folder as ghost-mgr and I receive the following error:

There was no need to reinstall Nginx as this was running. You needed to check or share the relevant config.

It appears that you have broken Nginx. Check the error logs.