Ghost home page does not appear

My ghost installation was working up until about a week ago.I have installed ghost on a digitalocean droplet (did not use one-click).

When I relaunched it, it appears to be successfully running, but when I go to my domain, I only see the nginx homepage.

This is what I see:

And here is my config:
{
“url”: “https://katherinepully.com”,
“server”: {
“port”: 2368,
“host”: “127.0.0.1”
},
“database”: {
“client”: “mysql”,
“connection”: {
“host”: “localhost”,
“user”: “root”,
“password”: “[password]”,
“database”: “ghost_prod”
}
},
“mail”: {
“transport”: “Direct”
},
“logging”: {
“transports”: [
“file”,
“stdout”
]
},
“process”: “systemd”,
“paths”: {
“contentPath”: “/home/kpully/ghost/content”
}
}

Hi kpully,

  1. Have you pointed your nameservers correctly to your Digital Ocean droplet?
  2. Have you added the domain in your droplet’s domain settings?

That could be the issue.

If the above is in order, you can try running the installation process detailed by Digital Ocean again: https://marketplace.digitalocean.com/apps/ghost#getting-started

Best of luck!

Interestingly it’s happening with the IP address as well, so I don’t think it’s an issue with the name servers?
For example, when I go straight to the IP address, I see nginx instead of ghost.

Site seems to be working for me now @kpully! I just tried visiting the URL in your screenshot and I’m seeing your site :+1:

Thanks for your replay David - I actually created a new droplet and re-directed my domain to that droplet’s IP as I wasn’t able to figure out the underlying issue.