Ghost email settings without www subdomain

Hi,

I use Ghost and its member area.

I would like the email to be sent without the www subdomain.

It give me an error when I publish an article…

image

Is there a configuration to touch?
I don’t want to lose the subdomain for the blog URL, however.

Thanks!

Hi Maxence! Unfortunately (to the best of my knowledge) that’s not possible – the email has to send from the main blog URL, so you’d have to make your root domain (without www) the main one for your site in order to use it for the email address.

What URL did you configure in your mailgun account?
Generally it’s recommended to use a dedicated subdomain for email sending (for example): mail.yubigeek.com .
Check out https://app.mailgun.com/app/sending/domains


If you insert the proper domain in the mailgun setting in ghost admin along with the Private API key, to be found at:
https://app.mailgun.com/app/account/security/api_keys

It should work. :slight_smile:

If i misunderstood you, and you’re just wondering about the subdomain.
I would encourage you to change your ghost url and implement a permanent 301 redirect with your DNS Service.
That way your visitors could still reach you over www

1 Like

Hello,

I don’t want to use a subdomain for Mailgun. And I especially want to be free to change the sending address on Ghost so that the sending of mail works and have a real sending email address (contact@domain.com and not contact@www.domain.com).

The save button does not work, it does not save the field.

Thank you.

Maxence.

in 3.19.0 we added the ability to change the from address to any email address that you can verify.

@primax, when you say “save button” what do you mean exactly? Can you please confirm what version of Ghost you are using, and also share screenshots or a loom or something of what you’re seeing?

I use Ghost 3.21.1 version.

But, when I save the form, the system add www subdomain on email… and I can’t change the from email…

The system takes the domain of blog and not the from email address I write.

Did you press the “Update from address” button?

Yes of course, and immediately after, the address is changed to contact@www.domain.com

Yep, that’s the correct behaviour. The form should update to tell you that a confirmation email has been sent. You need to click the link in the confirmation email to get the value to update.

OK I found the solution.

I put a bad Mailgun API key in Email newsletter settings on labs.

And email doesn’t works to validate because the mail configuration of Ghost in config.production.json was bad.

Thanks for help.

Maxence.