Ghost email subscribe is giving "Failed to sign up, please try again" error

Hi all, I hope you are well.

I’m using Ghost 4.33 on DigitalOcean Droplet. The site is running well.

I have been editing the Casper theme. Mostly cosmetic updates.

I signed u pfor Mailgun and got my email, private password. etc. I followed number of guides to set up the email. but I still struggle to make it work. Not having any error log makes things reallydifficult.

I updated my
config.production.json

  "mail": {
    "transport": "SMTP",
    "options": {
      "service": "Mailgun",
      "host": "smtp.mailgun.org",
      "port": 587,
      "secureConnection": true,
      "auth": {
        "user": "postmaster@blog.mywebsite.com",
        "pass": "mylooooooongpassword"
      }
    }
  },

I didnt make any change to Signup form. Im using the custom Casper form.

I also updated the Settings with API.

Any idea forthe solution? Thnak you , any help is greatly appreciated. stay safe.

The “Mailgun domain” setting you’ve entered does not look correct - you should try using the link below the input “Find your Mailgun region and domain here” to find the correct one!

Hi Fabien, I trust you are well.

Thank you for the quick reply. This is the domain name I see in my account though

Screenshot 2022-01-23 at 22.27.01

Ah - that little question mark there looks like you haven’t verified the DNS for your domain - I think you need to click on the domain and follow the instructions there!

Hey Fabien, thank you for helping out. you are the best : )

I just did the DNS following with Ghost Restart. but its still same.
Screenshot 2022-01-23 at 22.47.46

I think we’re going to need to take a look at your error logs to continue to debug this - can your share the logs of the error?

You can see your logs by running ghost log - docs here Ghost-CLI - A fully loaded tool for installation and configuration

ah cool. So that’s how we see the log. I was trying to find that. :) thank you!

It looks like something related to Routes and SSL


[2022-01-24 09:51:04] INFO "GET /members/api/site/" 304 20ms
[2022-01-24 09:51:04] INFO "GET /" 200 73ms
[2022-01-24 09:51:05] INFO "GET /members/api/member/" 204 1ms
[2022-01-24 09:51:05] INFO "GET /members/api/site/" 200 16ms
[2022-01-24 09:51:11] INFO "GET /favicon.ico" 200 2ms
[2022-01-24 09:51:14] ERROR

NAME: EmailError
CODE: ESOCKET
MESSAGE: Failed to send email. Reason: 139768439764864:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:../deps/openssl/openssl/ssl/record/ssl3_record.c:332:
.

level: normal

"Please see https://ghost.org/docs/config/#mail for instructions on configuring email."
Error: 139768439764864:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:../deps/openssl/openssl/ssl/record/ssl3_record.c:332:
.


[2022-01-24 09:51:14] INFO "POST /members/api/send-magic-link/" 500 61ms

SOLVED!!! Phew!

I found this answer in the forum worked for me Ghost unable to send emails - #12 by EmpiricalEE

I changed my port number to port 465 and it worked!

Thank you @fabien for guiding me to Ghost Log. It helped to go on the right direction.

1 Like