Ghost Explore: refused connection

I’ve got my own website, and I added it to Explore with no issues. But every time I try to check it out, I get this "euaggelion.blog.br refused the connection" error.

I’m using CloudFlare to handle DNS, cache, and SSL certificates. I haven’t set any rules for WAF (Web Application Firewall), I saw in another discussion that this could be the problem, but I don’t know how to solve it.

I checked the console, and the error message looks like this: "Refused to display 'https://euaggelion.blog.br/' in a frame because it set 'X-Frame-Options' to 'sameorigin'."

Strange. It should detect the header and not attempt to show the site in an iframe. I’ll have a look at this.

2 Likes

@JamilFilho This is fixed now. Thanks for pointing out this bug.

Because of the header X-Frame-Options being set to sameorigin we can’t show the site in an iframe, so it will open a new tab for it instead.

1 Like