I can't add my site to Ghost Explore

I can’t add my site to Ghost Explore.
My installation runs on Docker version 5.60.0.
But whenever I want to add them, an error comes up that is not described in more detail.
What can that do?
Many thanks for the answer in advance!

It’s likely because you don’t have any content on your site. You need at least a post that isn’t default content.

1 Like

It looks like another issue is that Cloudflare is preventing access to your site. Please check your Cloudflare settings to see if you can find anything that might be interfering with these requests.

1 Like

Cloudflare will block access from ghost explore if turn on Bot Fighting in WAFsetting.

@RyanF @cuongtran
Hello everyone, my first article has been created (and hopefully there will be more soon), but I still have a question; how do i set the cloudflare waf settings to keep this from being blocked? But I don’t want to turn off the bot lock mode…

I’m using Cloudflare Tunnel.

I’ve had this same issue for a while, except I do not have bot fighting mode on. I’m assuming it has something to do with the cloudflare tunnel since I never had this issue before switching to using one.

If I go here and try to add it manually it doesn’t recognize that I’m using ghost.


Yes, thanks for the info, I’ve already tried that. But it only works if I disable the bot lockout.

I wonder what we are doing that’s opposite. I don’t use bot lockout and I can’t do it either. Do you have any rules in WAF?

No - as I said, I only use Cloudflare Tunnel.
I don’t have any rules in WAF, just bot fight mode on. Because of these it didn’t work; I don’t like to disable it either.

What if you disable it long enough to submit your site to explore and then turn it back on? Does it stay in the list?

Yes, I’ve thought of that too - and I meant that the “bot” needs access all the time because it’s not always reading the latest website data, right?

It actually won’t. Because Explore is meant to be updated on a regular base, sites that Explore can’t access anymore will be removed automatically after a bit.

Do you know any solution for this?

I had a similar issue. Adding a WAF skip rule for URI Path equals /ghost/api/v2/admin/site/ fixed it for me.

@SchBenedikt & @Benn Not sure about the settings options in CloudFlare. But if you can enable requests coming from Explore — Browse publications & featured writers in general, that would be ideal.

I would also update the URI path (if possible) to omit the API version or use canary, as this can and will probably change in the future. You’ll need to have two URI on that white list:

  1. /ghost/api/canary/admin/site and/or /ghost/api/admin/site
  2. /ghost/api/admin/explore

I hope this helps :blush:


Thanks for the tip - we actually have Cloudflare disabled now because it has also blocked Google crawl bots (also interesting to know!)
I also suspect that a WAF rule doesn’t help because it only works AFTER the bot is blocked (as you can see in the picture.)
Nevertheless, thank you for your efforts!

Yup. I just checked and the regular update works now for your site! Thanks for sharing what you changed!

Thanks, it’s great that this is now public!
Now I just need subscribers & visitors!

1 Like

I added these on mine and it shows that they are being skipped in the events log, but I still get an error.

Maybe I’ll just skip the cloudflare tunnel as well since I can’t seem to find a working solution.