Ghost Import fail: Import failed Request is larger than the maximum file size the server allows

My site is https://cameronincarnate.com
Ghost v 3.5.0
One-click install DigitalOcean hosting on Ubuntu 18.04
Microsoft Edge and Google Chrome

Import failed
Request is larger than the maximum file size the server allows

Trying to import Wordpress export file using WordPress to Ghost official plugin (filesize is 101.8 MB)

What a fortuitous event. I just responded to someone with the same problem today:

From: Import failed - I cannot import a migration archive, it fails!

For you though, I’d probably do something more reasonable, like 500M

1 Like

Thanks a lot!

No problem. Let me know how it works out for you.

I seem to be facing something similar.
I’ve updated client_max to 5G and it still won’t start the import process.

Any ideas on what else could be throwing it off?

Update:

both nginx and Ghost tail give no errors.
The rejection happens instantly when clicking the import button. I’m clueless at this point :frowning:

First I thought of timeout, but since it rejects it instantly, it must be something else.
Did you restart nginx after changing the settings? Is there something in the logs?

The rejection ended up being from Cloudflare.
It turns out their free CDN has a limit of 100M upload. I hope this saves someone down the road the trouble I ended up going through with this!

@vikaspotluri123 continues to save the day with my Ghost journey! :heart:

1 Like