Ghost installation created on linux cannot run on Windows due to symlink "current"

Hi, I created a ghost instance on linux Ubuntu, where I managed to start it on localhost, and everything was fine. Then, I pushed repo to github and I pulled on a Windows machine. I need to run it locally as well. But upon trying, I discovered that Ghost contains the symlink “current” which works on Linux but does not work on Windows. When running commands trying to start ghost, I get this output:

Found a development config but not a production config, running in development mode instead
√ Checking current folder permissions
√ Validating config
√ Checking memory availability
√ Checking binary dependencies
× Starting Ghost: ghost-local-1
A GhostError occurred.

throw err;

Error: Cannot find module ‘D:\Projects\admin\current\index.js’
at Function.Module._resolveFilename (internal/modules/cjs/loader.js:794:15)
at Function.Module._load (internal/modules/cjs/loader.js:687:27)
at Function.Module.runMain (internal/modules/cjs/loader.js:1025:10)
at internal/main/run_main_module.js:17:11 {

Debug Information:
OS: Microsoft Windows 10 Pro, v10.0.19041
Node Version: v12.13.0
Ghost Version: 4.2.0
Ghost-CLI Version: 1.16.3
Environment: development
Command: ‘ghost start’

If you aren’t running the latest version of Ghost, the first thing we will ask you to do is update to the latest version of Ghost.


  • How was Ghost installed and configured?
    → Ghost was installed in Powershell with npm install -g ghost-cli@latest.
  • What Node version, database, OS & browser are you using? node -v shows v12.13.0.
  • What errors or information do you see in the console? see above.
  • What steps could someone else take to reproduce the issue you’re having? create a ghost installation on linux, push it to github, pull on a windows 10 machine, try to start it.

Any ideas? Thanks,

PS edit ---- I also tried now the other way around: creating a ghost instance on Windows then pushing to github, then pulling on linux. Its the same. On Windows a shortcut is being created instead of a symlink. So,it looks like instances created on an unix OS cannot be used on windows.

I also did my best on activating symlinks on Win - reinstalled git with symlinks true, tried powershell admin, activated windows developer mode, etc etc.

I undertstand that symlinks are not well supported in Windows but why did you even have to use such a method?! Honestly, what an absolutely horrendous design decision, making the starting of ghost OS-dependant.