Ghost start throws a ProcessError

#1

Hello, everyone!
Someting went wrong when I ran ghost start :

A ProcessError occurred.

Message: Command failed: /bin/sh -c sudo -S -p ‘#node-sudo-passwd#’ systemctl is-active ghost_freekingd-com
#node-sudo-passwd#
unknown

Exit code: 3

Debug Information:
OS: CentOS, v7.5.1804
Node Version: v10.15.3
Ghost-CLI Version: 1.9.9
Environment: production
Command: ‘ghost start’

Additional log info available in: /home/ghost_doge/.ghost/logs/ghost-cli-debug-2019-04-03T09_56_15_991Z.log

Try running ghost doctor to check your system for known issues.

I have tried to solve this issue:

  • systemctl start ghost_freekingd-com --> nothing; systemctl is-active ghost_freekingd-com --> failed.
  • systemctl daemon-reload --> nothing.
  • No more info in the log file.
  • ghost doctor returned the same error.

After I read the troubleshooting. Incredibly, ghost run had worked, I could even visit my site. So I replaced ghost start with nohup ghost run & temporarily.

I am still worried about whether it will be affected by starting ghost in this unorthodox way. I would greatly appriciate any advice to this case.

Thanks all.

closed #2

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.