Ghost v2.1.1 is not compatible with this version of the CLI


#1

I’m trying to upgrade my AWS / Bitnami hosted Ghost blog from V 1.22.8 to version 2.x
(blog.salesinsider.io)

I’m running the command “ghost update” at /opt/bitnami/apps/ghost/htdocs/
but it is returning the error:
“Ghost v2.1.1 is not compatible with this version of the CLI” (Version 1.7.3 of the CLI)

I have a couple of questions…how do I know if I have the latest version of CLI?

Yes - I did run “sudo npm i -g ghost-cli@latest”

Even when I try to upgrade by using “Ghost Update --v1” I get the same error.

Any ideas would be helpful. Further below is a screenshot if it helps.

Thanks.


#2

The latest version of Ghost is 1.9.3. Based on what you’re saying, you might have multiple versions of Ghost CLI installed.


#3

How do i resolve it if that is the case?
What is the file name for CLI?


#4

As you know Ghost is open-source. The CLI is as well :slightly_smiling_face:
See head over https://github.com/TryGhost/Ghost-CLI then click release.

Cheers!


#5

Thanks - I’m aware of Github and that just confirms that the latest version of CLI is 1.9.3.

When I run “sudo npm i - g ghost-cli@latest” I see confirmation that I’ve installed CLI 1.9.3.

But when I run “Ghost Version” it still says CLI 1.7.3

So…I must have another version of CLI running somewhere.
How do I track it down / find it and remove it?

[btw, for kicks I ran “ghost update 1.25.5” and it successfully upgraded me from 1.22.8 to 1.25.5]

Isaac


#6

Can you share with us the result of

$ command -v ghost


#7

I get:

/opt/bitnami/apps/ghost/bin/ghost

Isaac


#8

I don’t know if you’re comfortable with your package manager on your system.

The path you gave to me, it’s the place where ghost-cli is installed. So what I suggest uninstalling ghost-cli (via npm or yarn), node, (and yarn) on your system via your package manager and install nvm and use the right version of node.js (nvm install 8.9.4 && nvm use 8.9.4). If you use yarn, install it without node (read this).

If ‘command -v ghost’ shows nothing, after uninstall with your package manager, you are in a good way.

If your need help, I can check via a remote session to help you with your problem. I had the same problem a few days ago.

Good luck!


#9

I had the same problem a month ago. I was able to solve it on my custom stack by simply running

sudo npm i -g ghost-cli

But if you are running Bitnami stack then it might not work.


#10

Rohitkrops
When I run “sudo npm i -g ghost-cli” it does an update to the CLI and says:

  • ghost-cli@1.9.4

added 6 packages, updated 8 packages andd moved 3 packages in 7.794s

I then run “ghost update”

and get system error

“Ghost v2.1.2 is not compatible with this version of the CLI”

It still thinks the Ghost-CLI version is 1.7.3


#11

I had the same problem, I needed to run ghost update --v1 to update the CLI to the most recent before I could update to v2