How To Configure Zoho Mail as Ghost's email?


#1

Hello again, since a few days I have been migrating my stuff from WordPress to Ghost, as I love Ghost!
Recently G Suit has stopped giving custom domain email address for free. So, I choose Zoho Mail. But, how do I configure Zoho Mail in Ghost on my production blog?

Here is my current configuration:

"mail":  {
  "transport": "SMTP",
  "options:: {
     "service": "ZohoMail",
     "auth": {
        "user": "no-reply@vasanthdeveloper.com",
        "pass: "********"
     }
  }
}

But, this is the error that I get when I click the send test email button:

Failed to send email. Reason: Message delivery failed: 553 Relaying disallowed as "Vasanth Developer" <ghost@vasanthdeveloper.com>.

How can I configure Zoho Mail for Ghost to send emails from?

  • Version 2.2.0
  • Environment production
  • Database mysql
  • Mail SMTP

Thank You :slight_smile:


#2

@vasanthdeveloper this is a issue on Zoho’s misconfiguration, read this post

Quoting here:

The error message "Relaying disallowed" will occur in the following cases.

From address that you are trying to add in SMTP client might not be listed in your Send Mail as section (in Zoho Mail). Please ensure that the email address that you are trying to use is one of the From addresses present in your Send Mail as section. Refer help to locate Send Mail as page.
                                                                  
If "Outgoing Server Requires Authentication" option is not enabled in the SMTP client. Ensure that the settings entered are correct by referring this link help page.

That said, you need to configure the “from” address to no-reply@vasanthdeveloper.com (assuming that is a valid sender) OR whitelist ghost@vasanthdeveloper.com in your Zoho account as a verified sender:

"mail":  {
    "from": "no-reply@vasanthdeveloper.com"
}

#3

Hello,
Thank you very much as that fixed the issue. But, how do I edit the default email template in Ghost? I would like to add my logo and customize it according to my taste.

Thanks in advance :slight_smile:


#4

@vasanthdeveloper you can override it read " Default template" in this section of the docs.


#5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.