How To Configure Zoho Mail as Ghost’s email?

I can’t send invites using Ghost’s default settings, so I tried to use my Zoho mail SMTP configuration.

This is how I’m setting it:

"mail": {
    "service": "ZOHO",
    "transport": "SMTP",
    "options": {
      "host": "smtp.zoho.com",
      "port": 465,
      "secureConnection": true,
      "auth": {
        "user": "address@domain.com",
        "password": "specific-app-password or account password"
      }
    }
  },

All I got is a " Invalid login - 535 Authentication Failed" message from the Ghost dashboard.

I’ve set an app specific password and even tried the account password, but it simply doesn’t work.

I had the same issue than yours, i think I solved it by moving the “service” under the options section.

"mail": {
    "transport": "SMTP",
    "options": {
        "service": "Mailgun",
        "host": "smtp.eu.mailgun.org",
        "port": 465,
        "secureConnection": true,
        "auth": {
            "user": "postmaster@example.mailgun.org",
            "pass": "1234567890"
        }
    }
}

@tadartefactorist I tried to do the same, but I still have the same error. And I changed the smtp setting to Gmail, what makes me think this is a problem with my host blocking ports or something related to Ghost itself. I updated to version 2.27.0, but the issue is still there.

Here is what I use for Mailgun.
EDIT: with the link https://github.com/firepress-org/ghostfire/blob/master/config.production.json#L13

I would check my server setup and port.