I think I broke it


It would seem that I have broken my website following an attempt to update it to the latest version.

I’m therefore looking for someone to assist me (paid).

Anyone out there that might want to give me a hand?


Might be worth posting the error details to see if we can point you to a quick fix.

…and details of the host system.

I’m hosting the website at Digital Ocean.

Upon logging in via shell, I run sudo -i -u ghost-mgr. That works :slight_smile:

Following that, I’ve tried a few commands.
sudo service ghost start
Failed to start ghost.service: Unit ghost.service not found.

And of course, ghost check-update

Command ‘ghost’ not found, did you mean:


I tink you run the command from the wrong folder…


  1. cd /var/www/ghost (The folder were you installed ghost - My is /var/www/ghost)
  2. ghost update --force
  3. ghost start

If any errors - Please post them here…

1 Like

Tried as you suggested, same issue

What’s the output from…

ghost doctor
ghost setup systemd

:/var/www/ghost$ ghost doctor

Command ‘ghost’ not found, did you mean:

What steps did you follow to install Ghost? Have you installed ghost-cli?

I’d installed it via the droplet from Digital Ocean.

I thought cli was installed.

First things first, can you rollback the DO server, e.g., restore a snapshot? If so, do this so you have a working production website.

If that’s an option, the next thing to do is create a clone, and use this to understand what’s happening and what steps are required for the upgrade. If DO pricing is similar to Linode, the clone will only cost a few dollars.

I’m a bit of a idiot. I completely forgot about backups.

I went ahead and rolled back to an older version and just like magic I’m back.

Then I started the upgrade process again and no problems.