I'm encountering an error while updating to the new version. Why could this be happening?

Hello, I’m getting the error in the screenshot I’ve attached below while updating Ghost to the new version. Can you please help me understand why this is happening?

How can I update from version 16.20.0 to 18.12.1?

As you figured out, support for Node 16 was dropped in Ghost 5.71.0. That’s why you can’t upgrade without issues.

Upgrading Node depends on how you set it up. If you have used nvm, you could simply do nvm install 18 and then nvm use 18.

If you have installed it manually, it might be a bit trickier. Here is a general overview – bug again, the exact steps will depend on how you installed node: How to Update Node and NPM to the Latest Version

1 Like

I had installed it with the command I provided below.

curl -sL https://deb.nodesource.com/setup_16.x | sudo -E bash

Then you should be able to upgrade like this:

curl -sL https://deb.nodesource.com/setup_18.x | sudo -E bash -

sudo apt-get install -y nodejs

With the first command you setup the Node 18 repository, with the second command you install the newly available node version :slight_smile:

You can then check your node version with node -v


Thank you very much, I applied it, and it went smoothly. Thanks again, and I wish you a productive day.

1 Like

I updated Node.js using those commands, then during the Ghost update, a warning popped up. Without reading what it was about, I accidentally confirmed using the ‘y’ letter, and since then, the site has been down. It’s currently showing the error in the screenshot below. As far as I understand, the database seems to have gone missing. I tried to recreate it with the MySQL username and password, but there still seems to be an issue. The site isn’t opening. What could be the problem, and why would this happen?

I used the Ghost doctor command, and it gave an error on the screen.

Take a look at this thread:


I changed the part in the config file from to localhost, but it’s still giving the error mentioned below.

This seems to be unrelated to the node update and indicates that there is an issue with your mail configuration – I assume that was there before the upgrade, but you haven’t noticed.

smtp-relay.sendinblue.com is not a valid option for mail.options.service in your config.josn.

For SendinBlue that should be SendinBlue, according to nodemailer, the underlying package used by Ghost for transactional mails.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.