Installing second ghost instance MySQL auth error

I am trying to setup a second ghost instance.
I created a new directory /var/www/ghost2 and then ran ghost install from within that directory.
Went through setup and under MySQL settings I used the following:
username: root
pass: my root password

I then get this error as it tries to launch Ghost:

Am I using the wrong MySQL details?
I followed the instructions here:

Enter your MySQL username:

Enter your MySQL username. If you have already created a mysql user, password and database with the correct credentials ready for Ghost, enter those details now. Else, enter root and your MySQL root password and Ghost will generate a custom MySQL user for you.

Referring to the above, I entered my vps root user and password. I assume this is incorrect? Must I use a
different root username and password for MySQL? If so, how do I know what it is?

How can I fix this? I will appreciate the assistance.


  • What’s your URL? This is the easiest way for others to debug your issue
    2nd add-on site:

  • What version of Ghost are you using?

  • What configuration?
    Digital Ocean 1-click install, standard config?

  • What browser?

  • What errors or information do you see in the console?

  • What steps could someone else take to reproduce the issue you’re having?

I think I possibly got it working now.

I Googled the error code and came upon the FAQ of Ghost. So I manually created a database and user, added that to the config file and seems like it worked.

How can I make sure that the instance will always run/reboot? Does Ghost-CLI do it for you? Is that the Systemd setup?

Yep, when Ghost setups up systemd, your OS is configured to start your Ghost instance when the system strats :)

1 Like


I am surprised I have not come across a blog yet with a tutorial for setting up a second instance using the Ghost-CLI. It was pretty darn easy.

The process I followed to get my two blogs running off one VPS:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.