"Internal server error, cannot edit post. Cannot read property '0' of undefined"

I’m trying to copy and paste a post over from WordPress, which I’ve attempted by copying the actual HTML code as well as by doing a straight-up copy and paste from the WordPress blog’s front end. However, both times, when I try and save the post in the Ghost editor, I get hit up with the message “Internal server error, cannot edit post. Cannot read property ‘0’ of undefined”. Might this be because there’s a null character in that post or something, or might it be due to something on Ghost’s end?

Have you tried cutting and pasting from WordPress into a raw text file then copying from there into the Ghost editor?

1 Like

I had already tried using my code editor (Brackets) as the middle-man, as well as LibreOffice, but neither worked. But upon your suggestion I thought I’d try copy and pasting the material into an email, then to Ghost. That screwed up the formatting, but fixed the problem. Thanks for the nudge!

Cool. Glad you got it fixed.

1 Like

@Stromfeldt are you able to share the copied content with me so I can try to track down where the error is coming from? Feel free to DM me if it’s not shareable publicly

1 Like

I have the same issue as @Stromfeldt, @Kevin

Is there any e-mail address that I can send you the dump of the row that is causing the issue? I can provide with some more details about that but too.

This error was fixed in 2.34.0. However, DO NOT upgrade if you have any posts created in Ghost 0.x or 1.x, there’s a bug where editing posts created in those versions can result in content being lost.

We’re currently working on a hotfix, please keep an eye on the GitHub releases for the next release.

1 Like

Thanks for the reply!

I just saw in the github that a version 2.35.0 was released (my ghost is running 2.33). May I update my ghost version to see if it will fix this bug (asking this because on versions 2.33 and 2.34, there’s a bit DO NOT USE label)?

@MuriloDelefrate yep, 2.35.0 is fine to upgrade to :+1:

Cool!!
I’m using Docker to run ghost, so I’ll wait the the 2.35 version there (https://hub.docker.com/_/ghost/ - if there’s anything I could do to help you guys on that, I could do it!)